Скорее всего модуль QT не установлен или установлен вне пределов PYTHONPATH

Интерпрeтатор завершив аварийно работу должен был выдать traceback, в котором он обычно объясняет свое поведение. Можно еще проверить наличие модуля, выполнив import QT в интерактивном интерпретаторе python

 

Да, можно. Даже с помощью представленного в статье GRC файла, чуть подкорректировав.

Проблема будет в том что оцифровывать. До оцифровки сигнал нужно будет как то выделить и усилить. Нужно как то максимально ослабить влияние бытовой сети 50 Гц. Вообщем над аналоговой частью приемника придется попотеть. 

По аналоговой части информацию можно найти на 136.su Там люди принимают частоты еще ниже чем SLF

GNU Radio — это программное обеспечение для цифровой обработки сигналов, написанное и используещее языки программирования C++ и Python. В его состав входят различные модули для выполнения оперции ЦОС.

Для работы с GNU Radio нужно знать цифровую обработку. С помощью GNU radio можно делать цифровые приемники/передачики, радиолокационные системы, обработку звука, видео, сигналов Wi-FI, GSM и т.д., но для этого нужно иметь как минимум устройства оцифровывающие эти сигналы.

у GNU Radio есть графическая утилита gnuradio-companion, которая в некотором роде избавляет от глубокого знания языков программирования, но от знаний хотя бы основ ЦОС не уйти

У GNU Radio есть пакетный менеджер PyBOMBS  — самый удобный способ установки фреймворка и добавления новых пакетов. Все делает сам и что ценно — можно добавить новый модуль
У штекера 3.5 мм обычно 3 контакта — «правый», «левый» и «корпус». Заземление нужно на «корпус». Заземление на низких частотах очень важный элемент приемной системы
Последовательно с полотном антенны. В 3.5 мм штекере использовал один, центральный, контакт

C образа ставили или вручную собирали? Какой девайс планируете использовать?

RTL-SDR сильно нагружает Raspberry Pi (даже при наличии 1 Гб RAM). FUNcube Dongle с полосой 192 кГц предпочтительней.

 

Python может импортировать только те модули,  которые лeжат в каталогах, указанных в sys.path

Проверить доступные каталоги можно так:

— запустить интерактивный интерпритатор

— затем

>>> import sys

>>> sys.path

появится вывод (в моем случае пути в ubuntu):

['', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/python2.7/dist-packages/wx-3.0-gtk2']

В списке должен быть виден путь до модуля numpy

Доступен ли модуль можно проверить, выполнив импортирование модуля

>>>import numpy

>>>

Если этого нет, то путь до модуля numpy нужно прописать в PYTHONPATH.

Коллеги! Каждый зарегистрированный пользоватетель может написать свою статью!

Все что написано мной, написано после практической реализации процесcа по мотивам официальных мануалов.

Если Вы считаете, что то написано не правильно, поправте! Это поможет многим, кто придет после Вас!

Я так же как и Вы на пути познания. Цель этого ресурса в том, что бы делится знаниями!

Давайте будем помогать друг другу!

73!

Уважаемый! Других способов, кроме как предложенных, производителем нет! Я сожалею, что у вас не получилось. Читайте внимательно мануалы. Все методы установки, это переводы официальной документации, опробованные автором статей.

Проверьте системные переменные.  Должны быть GRC_BLOCKS_PATH со значением  что то вроде C:\Program Files (x86)\gnuradio\share\gnuradio\grc\blocks

В переменой path должен быть путь C:\Anaconda\Lib\site-packages\PyQt4;

В переменной PYTHONPATH должен быть C:\Program Files (x86)\gnuradio\lib\site-packages

Вообще даже если вы пройдете этот уровень квеста gnuradio на Windows, вас ждут увлекательные инсталляции библиотек QT и WX. 

С live CD или ubuntu всетаки намного проще.

73!

 

Это значит, что python не видит библиотеку pygtk. Вероятно при установке pygtk забыли поставить крыжек, что то то типа "Add GNU .... to the system PATH for all users"

,py — это расширение файлов языка Python. У Вас скорее всего проблема с путями до интерпретатора. В переменной окружения должен быть путь до Python и до файлов библиотеки gnuradio.Попробуйте для начала сделать так:

— найдите где у вас установлен Python, файл python.exe (может python27.exe)

— в командной строке наберите /тут путь до интерпретатора/python.exe C:\Program Files (x86)\gnuradio\bin\gnuradio-companion.py

Я не пробывал, можно попробывать вот так.
Я так понял, вас смутило написание AMD64 в название образа. В своем FAQ разработчики прямо пишут, что пакет оптимизирован под Intel x86 и поддерживается 32 и 64 битными ОС (Windows, Mac). У меня все прекрасно работает на Intel Core i7.
Попробуйте с образа запустить. Я имено так и делал. Raspberry Pi у меня был с ОП 512 Мгб, подключил к нему RTL-SDR, запустил простой GRC — просмотр спектра. Все работало, правда сеть не проверял и мне показалось что 512 Мб было всетаки маловато

Спасибо за посказку.

Поправил.

GNU Radio можно поставить на Windows Но я бы рекомендовал использовать Live GNU Radio